SPOJ 104 HIGH - Highways(矩阵树定理)

HIGH - Highways

 

In some countries building highways takes a lot of time... Maybe that's because there are many possiblities to construct a network of highways and engineers can't make up their minds which one to choose. Suppose we have a list of cities that can be connected directly. Your task is to count how many ways there are to build such a network that between every two cities there exists exactly one path. Two networks differ if there are two cities that are connected directly in the first case and aren't in the second case. At most one highway connects two cities. No highway connects a city to itself. Highways are two-way.

Input

The input begins with the integer t, the number of test cases (equal to about 1000). Then t test cases follow. The first line of each test case contains two integers, the number of cities (1<=n<=12) and the number of direct connections between them. Each next line contains two integers a and b, which are numbers of cities that can be connected. Cities are numbered from 1 to n. Consecutive test cases are separated with one blank line.

Output

The number of ways to build the network, for every test case in a separate line. Assume that when there is only one city, the answer should be 1. The answer will fit in a signed 64-bit integer.

Example

Sample input:
4
4 5
3 4
4 2
2 3
1 2
1 3

2 1
2 1

1 0

3 3
1 2
2 3
3 1

Sample output:
8
1
1
3

生成树计数

1、构造 基尔霍夫矩阵(又叫拉普拉斯矩阵)

     n阶矩阵 

     若u、v之间有边相连 C[u][v]=C[v][u]=-1

     矩阵对角线为点的度数

2、求n-1阶主子式 的行列式的绝对值

     去掉第一行第一列 

  初等变换消成上三角矩阵

     对角线乘积为行列式

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
int n;
LL C[13][13],tmp[13];
int main()
{
    int T,m,u,v;
    LL t,ans;
    scanf("%d",&T);
    while(T--)
    {
        memset(C,0,sizeof(C));
        scanf("%d%d",&n,&m);
        while(m--)
        {
            scanf("%d%d",&u,&v);
            u--; v--;
            C[u][v]=-1; C[v][u]=-1;
            C[u][u]++;  C[v][v]++;
        }
        ans=1;
        for(int i=1;i<n;i++)
        {
            for(int j=i+1;j<n;j++)
                while(C[j][i])
                {
                    t=C[i][i]/C[j][i];
                    for(int k=i;k<n;k++) C[i][k]-=C[j][k]*t;
                    for(int k=i;k<n;k++) swap(C[i][k],C[j][k]);
                    ans=-ans;
                }
            ans*=C[i][i];
            if(!ans) break;
        }
        if(ans<0) ans=-ans;
        printf("%lld\n",ans);    
    }
}

 

 

posted @ 2017-08-23 14:47  TRTTG  阅读(488)  评论(0编辑  收藏  举报