The Triangle (简单动态规划)

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

题解:求取数字三角形从顶到底和最大的一条路,每次只能往左下或右下走,那我们的思路就是从底到顶动态规划即可,每次只需要取最大的,那到顶一定是最大的

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>

using namespace std;

int main()
{
	int n;
	scanf("%d",&n);
	int dp[105][105];
	for(int t=0;t<n;t++)
	{
		for(int j=0;j<=t;j++)
		{
		
		scanf("%d",&dp[t][j]);
	    }
	}
	for(int t=n-2;t>=0;t--)
	{
		for(int j=0;j<=t;j++)
		{
			dp[t][j]+=max(dp[t+1][j+1],dp[t+1][j]);
		}
	}
	printf("%d\n",dp[0][0]);
	
	
	return 0;
}

 

posted @ 2018-12-04 09:07  black_hole6  阅读(211)  评论(0编辑  收藏  举报