SDNU 1351.the Number of Department(并查集)

Description

    Company A has N employees, this company has lots of departments around the country. The employees who belong to different departments do not know each other, but if two employees are working in the same department they will know each other directly or indirectly (For example, 1 and 2 know each other directly,2 and 3 know each other directly, so 1 and 3 know each other indirectly, and they belong to the same department).
    These N employees are numbered from 1 to N.
    Now, giving you M informations about these N employees (two employees' number, who knows each other directly).
    If any people did not appear in the list of the M informations, these people belong to different departments.
    Now, you should calculate how many departments this company has.

Input

    The 1st line, N, ( 1<=N<=10000 ) the number of the employees belong to the company.
    The 2ed line, M, ( 1<=M<=100000 ) the number of the informations about these N employees.
    The next M lines, each line has two numbers, i and j, said that employee i and j knows each other directly.

Output

    The maximum number of the departments that belong to company A.

Sample Input

11 
9
1 2
4 5
3 4
1 3
5 6
7 10
5 10
6 10
8 9

Sample Output

3

Hint

 

Source

Unknown
思路:一开始在纠结到底是拓扑排序还是并查集。如果是拓扑排序的话,靠入度不好判断有几个部门。所以,应该是并查集...
#include <cstdio>
#include <iostream>
#include <cmath>
#include <string>
#include <cstring>
#include <algorithm>
#include <queue>
#include <vector>
#include <map>
using namespace std;
#define ll long long

const int inf = 0x3f3f3f3f;
const int mod = 1e9+7;

int f[100000+8], n, m, sum;

void init()
{
    for(int i = 1; i <= n; i++)
        f[i] = i;
}

int get(int v)
{
    if(f[v] == v)return v;
    else
    {
        f[v] = get(f[v]);
        return f[v];
    }
}

int merg(int x, int y)
{
    int t1 = get(x);
    int t2 = get(y);
    if(t1 != t2)///判断是否是直接或间接认识(判断是否为一个祖先)
        f[t2] = t1;///靠左原则,且路径压缩后根植也改变了
    return 0;
}

int main()
{
    scanf("%d%d", &n, &m);
    init();
    int a, b;
    for(int i = 0; i<m; i++)
    {
        scanf("%d%d", &a, &b);
        merg(a, b);
    }
    for(int i = 1; i <= n; i++)
        if(f[i] == i)sum++;
//    for(int i = 1; i <= n; i++)cout<<"i = "<<i<<"---"<<f[i]<<endl;
    printf("%d\n", sum);
    return 0;
}

 

posted @ 2019-07-29 14:55  明霞  阅读(191)  评论(0编辑  收藏  举报