poj 2187 Beauty Contest(二维凸包旋转卡壳)

D - Beauty Contest
Time Limit:3000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit Status

Description

Bessie, Farmer John's prize cow, has just won first place in a bovine beauty contest, earning the title 'Miss Cow World'. As a result, Bessie will make a tour of N (2 <= N <= 50,000) farms around the world in order to spread goodwill between farmers and their cows. For simplicity, the world will be represented as a two-dimensional plane, where each farm is located at a pair of integer coordinates (x,y), each having a value in the range -10,000 ... 10,000. No two farms share the same pair of coordinates. 

Even though Bessie travels directly in a straight line between pairs of farms, the distance between some farms can be quite large, so she wants to bring a suitcase full of hay with her so she has enough food to eat on each leg of her journey. Since Bessie refills her suitcase at every farm she visits, she wants to determine the maximum possible distance she might need to travel so she knows the size of suitcase she must bring.Help Bessie by computing the maximum distance among all pairs of farms. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Two space-separated integers x and y specifying coordinate of each farm 

Output

* Line 1: A single integer that is the squared distance between the pair of farms that are farthest apart from each other. 

Sample Input

4
0 0
0 1
1 1
1 0

Sample Output

2

Hint

Farm 1 (0, 0) and farm 3 (1, 1) have the longest distance (square root of 2) 
旋转卡壳动态图。
题意:给定n个点,2<=n<=50000,问两个点之间的最大距离的平方。
题解:n个点中距离最远的两个点,一定是对于每条边来说,所能构成的三角形面积最大
   的那个点与这条边的两个点的连线的这两条边中的一条边,证明过程参见上图。
   二维凸包旋转卡壳问题, 先用求出这些点所能构成的最大凸多边形,即二维凸包。
   然后逆时针遍历凸包的点和边,求对于某一条边来说使其构成三角形面积最大的点
   ,求出两条边长的较大值,更新最大距离即可。在遍历边的过程中,点不需要从头
   遍历,因为边和点是对应着的。求三角形面积的时候也不需要加绝对值,因为是有
   向面积逆向遍历,有向面积值一定是正的。
#include<cstdio>
#include<cmath>
#include<algorithm>
#define MAX 50010
using namespace std;
struct Point{
    double x,y;
    Point(double x=0,double y=0):x(x),y(y){}
};
Point P[MAX],ch[MAX];
typedef Point Vector;
Vector operator - (Point A,Point B)
{
    return Vector(A.x-B.x,A.y-B.y);
}
bool operator <(const Point &a,const Point &b)
{
    return a.x<b.x||(a.x==b.x&&a.y<b.y);
}
double Length(Vector A)
{
    return A.x*A.x+A.y*A.y;
}
double Cross(Vector A,Vector B)
{
    return A.x*B.y-A.y*B.x;
}
int ConvexHull(Point *p,int n)
{
    sort(p,p+n);
    int m=0;
    for(int i=0;i<n;i++)
    {
        while(m>1&&Cross(ch[m-1]-ch[m-2],p[i]-ch[m-2])<=0) m--;
        ch[m++]=p[i];
    }
    int k=m;
    for(int i=n-2;i>=0;i--)
    {
        while(m>k&&Cross(ch[m-1]-ch[m-2],p[i]-ch[m-2])<=0) m--;
        ch[m++]=p[i];
    }
    if(n>1) m--;
    return m;
}
double rotating_calipers(int n)
{
    int q=1;
    double ans=0.0;
    ch[n]=ch[0];
     for(int p=0;p<n;p++) //p是边 q是点
    {
      while(Cross(ch[p+1]-ch[p],ch[q+1]-ch[p])>Cross(ch[p+1]-ch[p],ch[q]-ch[p]))
            q=(q+1)%n;
    ans=max(ans,max(Length(ch[p]-ch[q]),Length(ch[p+1]-ch[q])));
     }
return ans;
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<n;i++)
        scanf("%lf%lf",&P[i].x,&P[i].y);
        int m=ConvexHull(P,n);
        double ans=rotating_calipers(m);
        printf("%0.0lf\n",ans);
    }
    return 0;
}

 //注意不能像C题uva10652一样用pc,因为那个题里是pc++,这里pc是0。

posted @ 2016-05-18 21:04  Ritchie丶  阅读(223)  评论(0编辑  收藏  举报