Sicily 1021 Couple

1021. Couples

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

 

N couples are standing in a circle, numbered consecutively clockwise from 1 to 2N. Husband and wife do not always stand together. We remove the couples who stand together until the circle is empty or we can't remove a couple any more.

Can we remove all the couples out of the circle?

 

Input

 

There may be several test cases in the input file. In each case, the first line is an integerN(1 <= N <= 100000)----the number of couples. In the following N lines, each line contains two integers ---- the numbers of each couple.
N = 0 indicates the end of the input.

 

Output

 

Output "Yes" if we can remove all the couples out of the circle. Otherwise, output "No".

 

Sample Input

4
1 4
2 3
5 6
7 8

2
1 3
2 4

0

Sample Output

Yes
No

Problem Source

ZSUACM Team Member

 

本题思路较为简单,给出N对夫妻关系,然后判断将从1到2N站成一个环的夫妻按照关系一对一对的移出直到环为空。

首先准备一个数组arr储存夫妻关系,如a与b为夫妻,那么有arr[a]=b且arr[b]=a。

然后建立一个栈st以储存元素,然后从1到2N将元素依次放入栈中,如果栈顶元素与即将放入的元素存在夫妻关系,即在arr数组中存在对应关系,则将栈顶元素移出,即将放入的元素跳过不再放入,相当于将夫妻移出这个环。

这样循环下去直到遍历所有元素,如果此时栈为空,则说明给出的要求能够实现,输出“Yes”;反之则无法实现,输出“No”。

代码如下:

#include <iostream>
#include <stack>
using namespace std;

int arr[200002];//存放夫妇对应编号

int main()
{
    int n,a,b;
    while(cin>>n&&n)
    {
        stack<int>st;
        for(int i=0;i<n;i++)
        {
            cin>>a>>b;
            arr[a]=b;
            arr[b]=a;
        }
        for(int i=1;i<=2*n;i++)
        {
            if(!st.empty()&&arr[i]==st.top())
			{
				st.pop();
			}  
            else 
			{
				st.push(i);
			}
        }
        if(st.empty())
		{
			cout<<"Yes"<<endl;
		}		
        else
		{
			cout<<"No"<<endl;
		}			
            
    }
    return 0;
}                                 

  

posted @ 2016-03-23 00:20  日天大哥哥  阅读(575)  评论(0编辑  收藏  举报