HDU 3549 Flow Problem

Flow Problem

Time Limit: 5000/5000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others)Total Submission(s): 18435 Accepted Submission(s): 8676

Problem Description

Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.

Input

The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)

Output

For each test cases, you should output the maximum flow from source 1 to sink N.

Sample Input

2
3 2
1 2 1
2 3 1
3 3
1 2 1
2 3 1
1 3 1

Sample Output

Case 1: 1
Case 2: 2

Author

HyperHexagon

Source

HyperHexagon’s Summer Gift (Original tasks)

Recommend

zhengfeng | We have carefully selected several similar problems for you: 1532 3572 3416 3081 3491

题意

​ n个点,m条边,求最大流。

解题思路

​ 增广路算法模板题。

代码

#include<stdio.h>
#include<iostream>
#include<vector>
#include<queue>
#include<string.h>
#include<algorithm>
using namespace std;
#define maxn 1005
#define inf 0x3f3f3f3f

int n,m;
struct Edge
{
    int from,to,cap,flow;
    Edge(int u,int v,int c,int f):from(u),to(v),cap(c),flow(f) {}
};
struct EdmondsKarp
{
    vector<Edge> edges;
    vector<int> G[maxn];
    int a[maxn];
    int p[maxn];

    void init(int n)
    {
        for(int i=0; i<n; i++)
            G[i].clear();
        edges.clear();
    }

    void addedge(int from,int to,int cap)
    {
        edges.push_back(Edge(from,to,cap,0));
        edges.push_back(Edge(to,from,0,0));
        int m=edges.size();
        G[from].push_back(m-2);
        G[to].push_back(m-1);
    }

    int Maxflow(int s,int t)
    {
        int flow=0;
        for(;;)
        {
            memset(a,0,sizeof(a));
            queue<int> q;
            a[s]=inf;
            q.push(s);
            while(!q.empty())
            {
                int x=q.front();
                q.pop();
                for(int i=0; i<G[x].size(); i++)
                {
                    Edge& e=edges[G[x][i]];
                    if(!a[e.to]&&e.cap>e.flow)
                    {
                        p[e.to]=G[x][i];
                        a[e.to]=min(a[x],e.cap-e.flow);
                        q.push(e.to);
                    }
                }
                if(a[t]) break;
            }
            if(!a[t]) break;
            for(int i=t; i!=s; i=edges[p[i]].from)
            {
                edges[p[i]].flow+=a[t];
                edges[p[i]^1].flow-=a[t];
            }
            flow+=a[t];
        }
        return flow;
    }
};
int main()
{
//    freopen("in.txt","r",stdin);
    EdmondsKarp E;
    int t;
    cin>>t;
    for(int k=1; k<=t; k++)
    {
        printf("Case %d: ",k);
        scanf("%d%d",&n,&m);
        E.init(n);
        int a,b,c;
        for(int i=0; i<m; i++)
        {
            cin>>a>>b>>c;
            E.addedge(a,b,c);
        }
        printf("%d\n",E.Maxflow(1,n));
    }
    return 0;
}
posted @ 2017-12-12 14:48  Refrain_Li  阅读(389)  评论(0编辑  收藏  举报