快速排序-字典排序

Phone List
Time Limit: 3000/1000 MS (Java/Others)   Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 312    Accepted Submission(s): 120


Problem Description 
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers: 
1. Emergency 911 
2. Alice 97 625 999 
3. Bob 91 12 54 26 
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent. 

Input 
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits. 

Output 
For each test case, output “YES” if the list is consistent, or “NO” otherwise. 

Sample Input 


911 
97625999 
91125426 

113 
12340 
123440 
12345 
98346 

Sample Output 
NO 
YES 

Source 
2008“网新国际杯”浙江省大学生程序设计竞赛——热身赛(3) 

Recommend 
lcy 


--------------------------------------------------------------------------------------------------- 

URL:http://acm.hdu.edu.cn/showproblem.php?pid=1671


解题思路: 
输入所有的号码->按字典排序->排序后每个号码与其相邻的下一个号码比较->输出结果 
考点:快速排序(否则会超时) 
代码: 

#include <stdio.h> 
#include <string.h> 
int partition(char a[][11],int p1,int p2) 
{ int i,j; 
  char x[11]; 
  i=p1; 
  j=p2; 
  strcpy(x,a); 
  while(i<j) 
  { while(strcmp(a[j],x)>=0&&i<j) j--; 
    if(i<j) 
    { strcpy(a,a[j]); 
      i++; 
    } 
    while(strcmp(a,x)<0&&i<j) i++; 
    if(i<j) 
    { strcpy(a[j],a); 
      j--; 
    } 
  } 
  strcpy(a,x); 
  return(i); 
} 
void sortquick(char a[][11],int p1,int p2) 
{ int p; 
  if(p1<p2) 
  { p=partition(a,p1,p2); 
    sortquick(a,p1,p-1); 
    sortquick(a,p+1,p2); 
  } 
} 
int pd(char a[][11],int n) 
{ int i,j; 
  for(i=0;i<n-1;i++) 
  { if(strlen(a)>strlen(a)) 

      continue; 
    j=0; 
    while(a[j]!='\0') 
    { if(a[j]!=a[j]) 
        break; 
      j++; 
    } 
    if(a[j]=='\0') 
      return(0); 
  } 
  return(1); 
} 
main() 
{ char a[10002][11]; 
  int t,n,i,j; 
  scanf("%d",&t); 
  for(i=0;i<t;i++) 
  { scanf("%d",&n); 
    getchar(); 
    for(j=0;j<n;j++) 
      gets(a[j]); 
    sortquick(a,0,n-1); 
    if(pd(a,n)) 
      printf("YES\n"); 
    else 
      printf("NO\n"); 
  } 
}

 

posted @ 2012-05-10 16:59  陈小怪  阅读(409)  评论(0编辑  收藏  举报