Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

题意:问从顶走到底时,所经过的数的和的最大值,在一个顶点可以选择走左下或者右下
思路:要是我们真的按题意从上往下走的话会很难选择。一:路径会一分再分;二:你不知道下面的数是大是小,是否有助于你成功。所以我们从下往上,从倒数第二层到第一层,每个节点都要判断加上左下的数大还是加上右下的数大,这样最后直接输出matrix[0][0]就行

#include <iostream>
using namespace std;
int main()
{
	int N,matrix[101][101];
	cin>>N;
	for(int i=0;i<N;i++)
	  for(int j=0;j<=i;j++)
	    cin>>matrix[i][j];
	for(int i=N-2;i>=0;i--)
	  for(int j=0;j<=i;j++)
	  {
	   if(matrix[i+1][j]>=matrix[i+1][j+1])
	     matrix[i][j]=matrix[i][j]+matrix[i+1][j];
	   else
	     matrix[i][j]=matrix[i][j]+matrix[i+1][j+1];	  	
	  }
      cout<<matrix[0][0]<<endl;
      return 0;
}
posted on 2015-03-16 17:03  星斗万千  阅读(116)  评论(0编辑  收藏  举报