Description

There are N little kids sittingin a circle, each of them are carrying some java beans in their hand. Theirteacher want to select M kids whoseated in M consecutiveseats and collect java beans from them.

Theteacher knows the number of java beans each kids has, now she wants to know themaximum number of java beans she can get from Mconsecutively seated kids. Can you help her?

Input

Thereare multiple test cases. The first line of input is an integer T indicating thenumber of test cases.

For eachtest case, the first line contains two integers N (1 ≤ N ≤ 200) and M (1 ≤ M  N). Here N and M are defined inabove description. The second line of each test case contains N integers Ci (1 ≤ Ci ≤ 1000) indicatingnumber of java beans the ith kidhave.

Output

For eachtest case, output the corresponding maximum java beans the teacher can collect.

Sample Input

2

5 2

7 3 1 3 9

6 6

13 28 12 10 20 75

Sample Output

16

158

#include <iostream>

#include <string.h>

using namespace std;

 

int main()

{

   int T;

   cin>>T;

   while(T--)

    {

           int N,M,sum=0,maxs=0;

           cin>>N>>M;

           int *P=new int[N];

           for(int i=0;i<N;i++)

              cin>>P[i];

           for(int k=0;k<N;k++)

           {

                  sum=0;

                  for(int i=k;i<k+M;i++)

               sum=sum+P[i%N];

           if(sum>maxs)

               maxs=sum;

           }

        cout<<maxs<<endl;

    }

       return0;

}

posted on 2015-03-24 10:16  星斗万千  阅读(111)  评论(0编辑  收藏  举报