poj 2488(简单dfs,注意方向)

    A Knight's Journey
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 22306   Accepted: 7546

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define maxn 26
int p,q,ans,fg;
int dir[8][2]={{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};//开始看的是网上的字典序方向,感觉和我的方向不一样,发现是人家思路和我不一样,我是按照dir数组里面来表示的搜索方向,是按照我的字典序
struct node 
{
	char a;
	int num;
}path[maxn*maxn];
int vis[maxn][maxn];
void dfs(int x,int y,int ret)
{
	int i,curX,curY;
	if(fg)
		return;
	if(vis[x][y])
		return;
	vis[x][y]=1;
	for(i=0;i<8;i++)
	{
		if(ret==ans)
		{
			fg=1;
			for(i=1;i<=ans;i++)
				printf("%c%d",path[i].a,path[i].num);
			printf("\n");
			return;
		}
		curX=x+dir[i][0];
		curY=y+dir[i][1];
		if(curX<1||curY<1||curX>p||curY>q||vis[curX][curY])
			continue;
		path[ret+1].a='A'+curY-1;
		path[ret+1].num=curX;
		dfs(curX,curY,ret+1);
		vis[curX][curY]=0;
	}                       
}
int main()
{
	int n;
	int t=1;
	scanf("%d\n",&n);
	while(n--)
	{
		scanf("%d%d",&p,&q);
		memset(vis,0,sizeof(vis));
		ans=q*p;
		fg=0;
		printf("Scenario #%d:\n",t++);
		path[1].a='A';
		path[1].num=1;
		dfs(1,1,1);
		if(!fg)
			printf("impossible\n");
		if(n!=0)
			printf("\n");
	}
	return 0;
}

 

posted @ 2012-10-28 20:46  M_cag  阅读(227)  评论(0编辑  收藏  举报