HD2144Calculate S(n)

Problem Description

Calculate S(n).
S(n)=13+23 +33 +......+n3 .

Input

Each line will contain one integer N(1 < n < 1000000000). Process to end of file.

Output

For each case, output the last four dights of S(N) in one line.

Sample Input

1 2

Sample Output

0001 0009

 

#include<iostream>
#include<cmath>
using namespace std;
int main()
{
    __int64 n,sum;
    while(cin>>n)
    {
        n = n%10000;
        sum=((n*(n+1)/2)*(n*(n+1)/2))%10000;  
        printf("%04I64d\n",sum);
    }
    return 0;
}

公式的话,可以用数学归纳法推。

posted @ 2013-09-15 18:50  兰幽  阅读(256)  评论(0编辑  收藏  举报