HDU 2057

A + B Again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 11594    Accepted Submission(s): 5049

Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming. Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too. Easy ? AC it !
 
Input
The input contains several test cases, please process to the end of the file. Each case consists of two hexadecimal integers A and B in a line seperated by a blank. The length of A and B is less than 15.
 
Output
For each test case,print the sum of A and B in hexadecimal in one line.
 
Sample Input
+A -A +1A 12 1A -9 -1A -12 1A -AA
 
Sample Output
0 2C 11 -2C -90
也就是十六进制的运算而已,读懂题目就可以直接做了
#include<stdio.h>
 int main()
 {
     __int64 a,b,ans;
     while(scanf("%I64X%I64X",&a,&b)!=EOF)
     {
         ans=a+b;
         if(ans<0)
         {
             printf("-");
             ans=-ans;
         }
         printf("%I64X\n",ans);
     }
     return 0;
 }
View Code

 

posted on 2013-07-15 00:43  Forgiving  阅读(114)  评论(0编辑  收藏  举报