1.链接地址

     https://vjudge.net/problem/POJ-1004

2.问题描述

 Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

输入样例

 

100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75

输出样例

$1581.42

3.解题思路

 每月的总余额加起来除以12即可,注意输出格式

4.算法实现源代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<string>
using namespace std;

int main()
{
    float sum = 0.0;
    float ans = 0.0;
    for(int i=0;i<12;i++)
    {
        scanf("%f",&ans);
        sum += ans;
    }
    sum /= 12;
    printf("$%.2f\n",sum);
}