AC日记——判断字符串是否为回文 openjudge 1.7 33

33:判断字符串是否为回文

总时间限制: 
1000ms
 
内存限制: 
65536kB
描述

输入一个字符串,输出该字符串是否回文。回文是指顺读和倒读都一样的字符串。

输入
输入为一行字符串(字符串中没有空白字符,字符串长度不超过100)。
输出
如果字符串是回文,输出yes;否则,输出no。
样例输入
abcdedcba
样例输出
yes

思路:

  模拟;

 

来,上代码:

#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;

int len;

string word;

bool check()
{
    int l=0,r=len-1;
    while(r>l)
    {
        if(word[l]!=word[r]) return false;
        l++,r--;
    }
    return true;
}

int main()
{
    cin>>word;
    len=word.length();
    if(check()) printf("yes\n");
    else printf("no\n");
    return 0;
} 

 

posted @ 2016-11-30 20:51  IIIIIIIIIU  阅读(665)  评论(0编辑  收藏  举报