HDU 1285-确定比赛名次

题目描述

有N个比赛队(1<=N<=500),编号依次为1,2,3,。。。。,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前。现在请你编程序确定排名。

输入

输入有若干组,每组中的第一行为二个数N(1<=N<=500),M;其中N表示队伍的个数,M表示接着有M行的输入数据。接下来的M行数据中,每行也有两个整数P1,P2表示即P1队赢了P2队

输出

给出一个符合要求的排名。输出时队伍号之间有空格,最后一名后面没有空格。
其他说明:符合条件的排名可能不是唯一的,此时要求输出时编号小的队伍在前;输入数据保证是正确的,即输入数据确保一定能有一个符合要求的排名。

Sample Input

4 3
1 2
2 3
4 3

Sample Output

1 2 4 3

解题思路:

该题是一道裸的拓扑排序的题目,解决拓扑排序的方法就是每一次把入度为0的点都删去,并保存在答案对列里面。输出来的顺序就是答案的顺序。

ac代码

#include <cstdio>
#include <iostream>
#include <queue>
#include <cstring>
using namespace std;
int m, n, cur;
bool  mapp[505][505];
int in_deep[505];
int ans[505];
priority_queue<int,vector<int>,greater<int> >q1;

void top_sort()
{
    priority_queue<int,vector<int>,greater<int> >q;
	int i, j, k, u;
	cur = 0;
	while (!q.empty())
		q.pop();
	for (i = 1; i <= m; i++)
	{

		if (in_deep[i] == 0)
		{
			q.push(i);

		}
	}

	while (!q.empty())
	{
		u = q.top();
		q.pop();
		ans[cur++] = u;
		for (i = 1; i <= m; i++)
		{
			if (mapp[u][i])
			{
				in_deep[i]--;
				if (in_deep[i] == 0)
					q.push(i);
			}
		}

	}
	for (i = 0; i < cur; i++)
		{
			if (i == 0)printf("%d", ans[i]);
			else printf(" %d", ans[i]);
		}
	printf("\n");
	return ;

}

int main()
{
	while (~scanf("%d%d", &m, &n))
	{
		memset(mapp, 0, sizeof(mapp));
		memset(in_deep, 0, sizeof(in_deep));
		int a, b;
		while (n--)
		{
			scanf("%d%d", &a, &b);
			if(!mapp[a][b])
            {
			mapp[a][b] = 1;
			in_deep[b]++;
            }
		}
		top_sort();
	}
	return 0;
}

总结:图论基础要搞好

posted @ 2018-08-13 09:27  IAMjm  阅读(171)  评论(0编辑  收藏  举报