UVAOJ 465 Overflow 大数

 Overflow 

Write a program that reads an expression consisting of two non-negative integer and an operator. Determine if either integer or the result of the expression is too large to be represented as a ``normal'' signed integer (typeinteger if you are working Pascal, type int if you are working in C).

 

Input

An unspecified number of lines. Each line will contain an integer n, one of the two operators+ or *, and another integer m.(0<=n,m<=1060)

 

Output

For each line of input, print the input followed by 0-3 lines containing as many of these three messages as are appropriate: "first number too big'', "second number too big'', "result too big''.

 

Sample Input

 

300 + 3
9999999999999999999999 + 11

 

Sample Output

 

300 + 3
9999999999999999999999 + 11
first number too big
result too big

 

这题应该属于杂题了...网上流传的一般都是用atof()将string转为float类型,

float也真是强大,能保存10^60的int..

.由于原来也一直都是写C++,但是java处理大数的方法非常多,于是第一次试试用java写大数题

大数处理的方法应该熟练掌握,,

特别注意测试数据可能出现00000000001 + 00000000000003 的情况,输出的时候要慎重

import java.io.*;
import java.util.*;
import java.math.*;
import java.text.*;
public class Main {

	/**
	 * @param args
	 */
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner cin = new Scanner(System.in);

		while(cin.hasNext()){
			String a1,b1,c1;
			String x;
			a1 = cin.next();
			x = cin.next();
			b1 = cin.next();
			BigInteger n = new BigInteger("2147483647");
			BigInteger a = new BigInteger(a1);
			BigInteger b = new BigInteger(b1);
			BigInteger c;
			System.out.println(a1.toString() + ' ' + x + ' ' + b1.toString());
			if(x.equals("+")){
				c = a.add(b);
				if(a.compareTo(n)>0){
					System.out.println("first number too big");
				}
				if(b.compareTo(n)>0){
					System.out.println("second number too big");
				}
				if(c.compareTo(n)>0){
					System.out.println("result too big");
				}
			}
			if(x.equals("*")){
				c = a.multiply(b);
				if(a.compareTo(n)>0){
					System.out.println("first number too big");
				}
				if(b.compareTo(n)>0){
					System.out.println("second number too big");
				}
				if(c.compareTo(n)>0){
					System.out.println("result too big");
				}
			}
		}
	}

}

 



posted @ 2012-05-12 13:34  Felix_F  阅读(170)  评论(0编辑  收藏  举报