POJ 3687 Labeling Balls



Labeling Balls
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 9221Accepted: 2510

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5
4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4

Source

POJ Founder Monthly Contest – 2008.08.31, windy7926778 

关键的地方就是要让标号小的尽量往前放,对于平行路径,小的头部不一定排在前面,但大的尾部一定排在后面!


#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>

using namespace std;

const int MAXN=222;

typedef struct
{
    int to,next;
}Edge;

Edge E[MAXN*MAXN];
int Adj[MAXN],Size,n,m,indegree[MAXN];
int res[MAXN];
void init()
{
    Size=0;
    memset(Adj,-1,sizeof(Adj));
}

void Add_Edge(int u,int v)
{
    E[Size].to=v;
    E[Size].next=Adj;
    Adj=Size++;
}

int topo()
{
    priority_queue<int> que;
    int i,u,cnt=n;
    for(int i=1;i<=n;i++)
    {
        if(indegree==0)
            que.push(i);
    }
    while(!que.empty())
    {
        u=que.top();
        que.pop();
        indegree--;
        res=cnt--;
        for(int i=Adj;~i;i=E.next)
        {
            indegree[E.to]--;
            if(indegree[E.to]==0)
                que.push(E.to);
        }
    }
    return cnt==0;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        init();
        memset(indegree,0,sizeof(indegree));
        scanf("%d%d",&n,&m);
        while(m--)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            Add_Edge(b,a);
            indegree[a]++;
        }
        if(topo()==0)
        {
            puts("-1");
        }
        else
        {
            for(int i=1;i<=n;printf(" "),i++)
            {
                printf("%d",res);
            }
            putchar(10);
        }
    }
    return 0;
}
* This source code was highlighted by YcdoiT. ( style: Codeblocks )
posted @ 2013-08-29 19:59  码代码的猿猿  阅读(156)  评论(0编辑  收藏  举报