TOJ 2419: Ferry Loading II

2419: Ferry Loading II 分享至QQ空间

Time Limit(Common/Java):1000MS/10000MS     Memory Limit:65536KByte
Total Submit: 4            Accepted:3

Description

Before bridges were common, ferries were used to transport cars across rivers. River ferries, unlike their larger cousins, run on a guide line and are powered by the river's current. Cars drive onto the ferry from one end, the ferry crosses the river, and the cars exit from the other end of the ferry. 
There is a ferry across the river that can take n cars across the river in t minutes and return in t minutes. m cars arrive at the ferry terminal by a given schedule. What is the earliest time that all the cars can be transported across the river? What is the minimum number of trips that the operator must make to deliver all cars by that time?

Input

The first line of input contains c, the number of test cases. Each test case begins with n, t, m. m lines follow, each giving the arrival time for a car (in minutes since the beginning of the day). The operator can run the ferry whenever he or she wishes, but can take only the cars that have arrived up to that time.

Output

For each test case, output a single line with two integers: the time, in minutes since the beginning of the day, when the last car is delivered to the other side of the river, and the minimum number of trips made by the ferry to carry the cars within that time. 

You may assume that 0 < n, t, m < 1440. The arrival times for each test case are in non-decreasing order.

Sample Input

 

2
2 10 10
0
10
20
30
40
50
60
70
80
90
2 10 3
10
30
40

Sample Output

 

100 5
50 2

Source

Waterloo Jan.25 2003

最早到达对岸的时间,取决于最后一辆车的被运送时间,所以最优策略是让最后一辆车先走

就是一个贪心+dp

 

#include<stdio.h>
int a[1445];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,t,m;
        scanf("%d%d%d",&n,&t,&m);
        for(int i=1;i<=m;i++)
            scanf("%d",&a[i]);
        a[0]=-t*2;
        int x=m%n,s=a[x];
        for(int i=1;i<=m/n;i++)
        {
            s+=t*2;
            if(a[n*i+x]>s)s=a[n*i+x];
        }
        printf("%d %d\n",s+t,(m-1)/n+1);
    }
    return 0;
}

 

 

 

posted @ 2017-10-30 07:50  暴力都不会的蒟蒻  阅读(348)  评论(0编辑  收藏  举报