PAT Spell It Right [非常简单]

1005 Spell It Right (20)(20 分)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10^100^).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five
#include <iostream>
#include <cstring>
#include <cstdio>
#include<map>
#include<stack>
using namespace std;
string str[]={"zero","one","two","three","four","five","six","seven","eight","nine"};
//{zero,one,two,three,four,five,six,seven,eight,nine};原来这些字符串在定义的时候都要加上双引号啊。
map<int,string> mp;
int main()
{

    //freopen("1.txt","r",stdin);
    string s;
    cin>>s;
    int n=s.size();
    int sum=0;
    for(int i=0;i<10;i++){
        mp[i]=str[i];

    }
    for(int i=0;i<n;i++){
        sum+=(s[i]-'0');
    }

    stack<string> sta;
    //得到这个数之后还得倒序输出。那就用个栈吧。
    int temp;
    if(sum==0)cout<<"zero";
    while(sum!=0){
        temp=sum%10;
        sum/=10;
        sta.push(mp[temp]);
    }
    while(!sta.empty()){
        cout<<sta.top();
        sta.pop();
        if(!sta.empty())
            cout<<" ";
    }
    return 0;
}

//这道题可以说是非常简单了,一看题目就很短,就是输入输出每位数相加后的和对应的英文。一开始提交的了19分,我就猜到是说如果输入0的话,我的程序没有输出,所以就加了一句如果是0,那么直接输出zero。emmm,已经两次碰到这样了,以后就直接考虑。加上这句之后就20分了。

posted @ 2018-07-19 13:27  lypbendlf  阅读(143)  评论(0编辑  收藏  举报