POJ 3438 Look and Say

Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 9175   Accepted: 5548

Description

The look and say sequence is defined as follows. Start with any string of digits as the first element in the sequence. Each subsequent element is defined from the previous one by "verbally" describing the previous element. For example, the string 122344111 can be described as "one 1, two 2's, one 3, two 4's, three 1's". Therefore, the element that comes after 122344111 in the sequence is 1122132431. Similarly, the string 101 comes after 1111111111. Notice that it is generally not possible to uniquely identify the previous element of a particular element. For example, a string of 112213243 1's also yields 1122132431 as the next element.

Input

The input consists of a number of cases. The first line gives the number of cases to follow. Each case consists of a line of up to 1000 digits.

Output

For each test case, print the string that follows the given string.

Sample Input

3
122344111
1111111111
12345

Sample Output

1122132431
101
1112131415

CODE:
#include <iostream>
#include <cstdio>
#include <cstring>
#define REP(i, s, n) for(int i = s; i <= n; i ++)
#define REP_(i, s, n) for(int i = n; i >= s; i --)
#define MAX_N 1000 + 10

using namespace std;

int main(){
    int T;
    scanf("%d", &T);
    char s[MAX_N];
    while(T --){
        scanf("%s",s + 1);
        int ls = strlen(s + 1);
        int node = 1, num = 1;
        while(node < ls){
            if(s[node] == s[node + 1]) num ++, node ++;
            else {
                printf("%d%c", num, s[node]);
                node ++; num = 1;
            }
        }
        if(s[ls] == s[ls - 1]) printf("%d%c", num, s[node]);
        else printf("1%c", s[node]);
        cout << endl;
    }
    return 0;
}

 

 
posted @ 2015-05-28 10:03  ALXPCUN  阅读(166)  评论(0编辑  收藏  举报