HDU2476:String painter(区间DP)
String painter
Time Limit: 5000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2304 Accepted Submission(s): 1007
Problem Description
There are two strings A and B with equal length. Both strings are made up of lower case letters. Now you have a powerful string painter. With the help of the painter, you can change a segment of characters of a string to any other character you want. That is, after using the painter, the segment is made up of only one kind of character. Now your task is to change A to B using string painter. What’s the minimum number of operations?
Input
Input contains multiple cases. Each case consists of two lines:
The first line contains string A.
The second line contains string B.
The length of both strings will not be greater than 100.
The first line contains string A.
The second line contains string B.
The length of both strings will not be greater than 100.
Output
A single line contains one integer representing the answer.
Sample Input
zzzzzfzzzzzabcdefedcba
abababababab
cdcdcdcdcdcd
Sample Output
67
代码:
View Code#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
char s1[105],s2[105];
int dp[105][105];//dp[i][j]为i~j的刷法
int ans[105],i,j,k,len;
int main()
{
while(~scanf("%s%s",s1,s2))
{
len = strlen(s1);
memset(dp,0,sizeof(dp));
for(j = 0; j<len; j++)
{
for(i = j; i>=0; i--)//j为尾,i为头
{
dp[i][j] = dp[i+1][j]+1;//先每个单独刷
for(k = i+1; k<=j; k++)//i到j中间所有的刷法
{
if(s2[i]==s2[k])
dp[i][j] = min(dp[i][j],(dp[i+1][k]+dp[k+1][j]));//i与k相同,寻找i刷到k的最优方案
}
}
}
for(i = 0; i<len; i++)
ans[i] = dp[0][i];//根据ans的定义先初始化
for(i = 0; i<len; i++)
{
if(s1[i] == s2[i])
{
if(i==0)
ans[i] = 0;
else
ans[i] = ans[i-1];//如果对应位置相等,这个位置可以不刷
}
else
{
for(j = 0; j<i; j++)
ans[i] = min(ans[i],ans[j]+dp[j+1][i]);//寻找j来分割区间得到最优解
}
}
printf("%d\n",ans[len-1]);
}
return 0;
}