A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence ( a1, a2, ..., aN) be any sequence ( ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input
7
1 7 3 5 9 4 8
Sample Output
4

动态规划

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <map>
#define Max 1001
using namespace std;

int s[1000];
int dp[1001];
int main()
{
    int n,d = 0;
    while(cin>>n){
    d = 1;
    for(int i = 1;i <= n;i ++)
    {
        dp[i] = 1;
        cin>>s[i];
    }

    for(int i = 2;i <= n;i ++)
    {
        for(int j = 1;j < i;j ++)
            if(s[i] > s[j])dp[i] = max(dp[i],dp[j] + 1);
        d = max(d,dp[i]);
    }
    cout<<d<<endl;}
}

二分加数组

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <map>
#define Max 1001
using namespace std;


int main()
{
    int n,d,no;
    int s[100000];
    while(cin>>n)
    {
        no = 0;
        while(n --)
        {
            cin>>d;
            if(!no || s[no - 1] < d)s[no ++] = d;
            else
            {
                int *p = upper_bound(s,s + no,d);
                *p = d;
            }
        }
        cout<<no<<endl;
    }
}