PAT1130:Infix Expression

1130. Infix Expression (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N ( <= 20 ) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

data left_child right_child

where data is a string of no more than 10 characters, left_child and right_child are the indices of this node's left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by -1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.

Figure 1
Figure 2

Output Specification:

For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.

Sample Input 1:
8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1
Sample Output 1:
(a+b)*(c*(-d))
Sample Input 2:
8
2.35 -1 -1
* 6 1
- -1 4
% 7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1
Sample Output 2:
(a*2.35)+(-(str%871))

 

思路

 

根据二叉树输出表达式。

1.根据输入数据构建树,用一个bool数组记录根节点的位置。

2.中序遍历输出二叉树就行。

 

代码

 

#include<iostream>
#include<vector>
using namespace std;
class Node
{
public:
    string data;
    int left,right;
};

vector<bool> isroot(20,true);

string inorder(const int root,const vector<Node>& tree,const int treeroot)
{
   if(root == -1)
     return "";
   if(tree[root].left == -1 && tree[root].right == -1)
     return tree[root].data;
   string left = inorder(tree[root].left,tree,treeroot);
   string right = inorder(tree[root].right,tree,treeroot);
   return root == treeroot?left + tree[root].data + right : "(" + left + tree[root].data + right + ")";
}

int main()
{
  int N;
  while(cin >> N)
  {
      //build tree
      vector<Node> tree(N + 1);
      for(int i = 1;i <= N;i++)
      {
          cin >> tree[i].data >> tree[i].left >> tree[i].right;
          if(tree[i].left != -1)
            isroot[tree[i].left] = false;
          if(tree[i].right != -1)
            isroot[tree[i].right] = false;
      }

      //find root
      int root = -1;
      for(int i = 1;i <= N;i++)
      {
          if(isroot[i])
          {
              root = i;
              break;
          }
      }
      //inorder output
      cout << inorder(root,tree,root) << endl;
  }
}

 

  

 

posted @ 2017-10-30 14:27  0kk470  阅读(378)  评论(0编辑  收藏  举报